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Dreamweaver Bayside Beat Notes

Part 1 
	Site Organization:
Local Folder – your working directory, usually a place on your hard drive.  Dreamweaver calls this your local site root.  Put allyour existing assets here:  images, video, text content, etc.)
Remote Folder – this is on the computer that runs your web server, the computer that makes your site public.

	Hands-On Practice:
1.  Create a new folder on your student drive named “dwsite”.
2. Download the practice files from your school computer’s Data File>Web Design>first_website_pt1.zip and put it in your folder called “dwsite”.
3. The first_website_pt1 folder contains two folders (bayside_beat and content).  Copy the bayside_beat folder into your dwsite folder.  This will be your root folder for your Dreamweaver site.

	Define the Site:
Dreamweaver needs to know where your site files are to create all the internal links correctly.
	Hands-On Practice:
1.  Start Dreamweaver. Select Site>New Site.
2. In the Site Setup dialog box enter the following:
Enter Bayside Beat as the name of the site.
Click the folder icon next to Local Site Folder to browse to and select the bayside_beat folder.
3.  Click Save.


	Naming Files and Folders:
· Organize files and folders logically.
· Create separate, appropriately named folders for images, videos, style sheets, text content, etc.
· File and folder names should not contain spaces or characters like:  /?%*\<>
· You may use - _ abc,123
· Keep names short but meaningful since they may end up as part of a web page’s URL
· Use all lowercase letters to avoid problems of connecting with a host server later on.
	












Continued on Back

	Dreamweaver Lesson 1 Review Questions
1.  What does a local root site folder (your working directory) contain?
2. Why did we need to define our local site folder for Dreamweaver?
3. Why is it important to keep files and folders carefully organized when creating a website?
4.  Name two things to remember when you are naming files and folders for a website.  

	Instructions:  In a new Word document, re-type the review questions to the left.  Type your response to each question.  Include a header with your name, DW Lesson 1 Questions, and Class Period.

	Other Notes:
	












Dreamweaver Bayside Beat Notes
Part 2a
Create New Page, Build Basic HTML Structure, Unordered List, <div> Elements





	Create a new Site:
Use the Insert panel to generate necessary code automatically.  Dreamweaver creates the code but always check that it is nested properly.
Build basic structure before adding text, images and links.
Remember that users will be accessing your website on a variety of screen resolutions (tablets, phones, desktops)
HTML 5 is the newest standard of the markup language.  It is default in Dreamweaver CC.  HTML5 is backwards compatible with all web browsers in current use.  
Index.html is a good choice for a site’s home page.
An * next to the file name means that the file has been changed and the changes need to be saved.
	Hands-On Practice:
**Note: You must have a local site folder defined in Dreamweaver before doing this lesson.  If not, do Part 1!
1.  In Dreamweaver, select the  bayside_beat folder in the Files panel.
2. Select File>New
3. In the dialog box select the following: Page Type: HTML, Layout: <none>, DocType: HTML5.  Click Create.
4. Select File>Save.  In the Save As dialog box, make sure you’re in the bayside_beat folder. Enter “index.html in the File Name text box.  Click Save.
5. Give your site a title.  In the Document Title text box (at the top of the page or in the Property inspector) type “Bayside Beat: Cable Cars”.
6. Save your work.  (Ctrl +S)

	Building HTML Structure:
The <div> tag is one of the basic building blocks of web page layout. It acts as a container for page elements like images and text.  The <div> tag groups elements together so they can be styled consistently later.

We will use CSS later to position elements as well as change text color, backgrounds, and artistic effects.
Insert Panel We will use the Insert panel in Dreamweaver to build the structure of this site. The Insert panel has several sub-panels.  We will use the Structure category.

Work in Split View so you can see the design and underlying code at the same time.  You can split horizontally or vertically.  Split horizontally for this lesson, Design on top and Code on bottom.

Remember, CTRL +Z will undo accidents!

All visible content of a web page goes between the <body></body> tags.

	Hands-On Practice:
1.  Change to Split view by clicking the Split button at the top left of document window.
2. Click so the insertion point is between the <body></body> tags.
3. Create a wrapper:  Open the Insert panel by clicking the Insert tab. Select the Structure category by clicking the down arrow next to Common.  Click Div.
4. In the Insert Div dialog box, make the following specifications:  Insert: “At Insertion Point”, Class: (blank), ID: “wrapper”. Click OK
5. Delete the placeholder text of the new <div>


Continued on next page
6. With insertion point between <div></div>, click Header in the Insert panel. In the Header dialog box specify the following: Insert: “At insertion point”, Class: (blank), ID: “top”.  Click OK.
7. Delete the placeholder text and replace it by typing “Bayside Beat”. Change that text to a h1 heading in the Property inspector.





	Create a Navigation Bar:
The navigation bar will be created as an unordered (bulleted) list.

Use the dialog box to specify where to insert an element relative to other elements in the document.
	Hands-On Practice:
1.  Add a <nav> element.  Click Navigation in the Insert panel.  In the dialog box specify: Insert:”Before end of tag”, Select <header id=”top”> from the second menu. ID: “mainnav”.  Click OK.
2. Create the navigation bar as an unordered list. Select only the placeholder text inside the <nav>. Click Unordered list in the Insert panel. Click List Item in the Insert Panel. Replace the placeholder text with “Home”.  Press Enter. Click List Item in the Insert panel, and type “Sightseeing”.  Repeat these steps to add three more items: “Eating Out”, “What’s On”, and “Where to Stay”








	Create more <div> elements:
These elements will act as containers to help us style with CSS later.
<div id=”hero”>
<article id=”main”>
<article id=”sidebar”>
<footer>
**In design terms, a large image is usually called a “hero image”.  
The HTML Family Tree:   Elements nested inside an outer element are referred to as children or descendants.  The outer element is know as the parent or ancestor.  Elements that are at the same level of the HTML structure are called siblings.  Like you, HTML elements inherit most styles from their parents, but they can also have individual styles of their own.  
	Hands-On Practice:
1.  Click Div in the Insert panel.  In the dialog box, specify the following: Insert: After Tag, <header id=”top”>, Class: (blank), ID: “hero”.  Delete the placeholder text in the hero<div>.


Continued on next page
2. Create space for the site’s article. Click to make the insertion point within the <div id=”hero”></div> tags.  Click Article in the Insert panel. In the dialog box, specify: Insert: At insertion point, Class: blank, ID: (blank).  Click OK.
3. Add another< article>. Click to make the insertion point after the hero</div> tag.  Click Article.  In the dialog box specify: Insert: After tag, <div id=”hero”>, ID: “main”.  Click OK. 
4. Add an <aside>element.  Click Aside in the Insert panel.  Specify the following: Insert: After tag, <article id=”main”>, ID: “sidebar”.  Click OK.
5. Add a <footer>.  Click Footer in the Insert panel.  Specify: Insert: After tag, <aside id=”sidebar”>, ID: (blank).  Click OK.
6. Ctrl+S to Save

	Dreamweaver Lesson 2a Review Questions
1.  In Dreamweaver, what does an * on the document tab mean?
2. The <div> tag is one of the basic building blocks of web page layout.  What does it do? 
3.  Why is it beneficial to work in Split view when creating a web page in Dreamweaver?
4.  We created a navigation menu for the Bayside Beat website.  Explain the basic steps we took to create the navigation menu and name the panel we used in Dreamweaver.
5.  What do children, parents, and siblings have to do with HTML?


	Instructions:  In a new Word document, re-type the review questions to the left.  Type your response to each question.  Include a header with your name, DW Lesson 2a Questions, and Class Period.

	Other Notes:









	



Dreamweaver Bayside Beat Notes
Part 2b
Add Text Content, Paste Special, Footer






	Site Content:
Rich Text Format (.rtf)files – These types of files can be read by almost all word processors regardless of version or operating system.  They have less risk of carrying viruses and are usually smaller file size (as long as there are no images or graphics, just text.)


Placeholder Text – This is descriptive text that is displayed in an input field until it is replaced with some other text specified by you.

Paste Special – This command, found under the Dreamweaver Edit menu, allows you to preserve the structure of word-processed text.


	Hands-On Practice:
7. From the folder, first_website_pt1, open the folder called content.  Open content1.rtf.  It should open a document in Word.
8. Copy and paste content into your site by: Select the heading “Be Where It’s At” and the paragraph that follows.  Copy it Ctrl+C.  
9. In Dreamweaver, select the placeholder text in the first <article> element. Select Edit> Paste Special  (Ctrl+Shift+V).  In the dialog box select the third radio button.  Click OK.
10. In Word, copy (Ctrl+C) the heading “Riding the Cable Cars” and the 3 following paragraphs.  
11. In Dreamweaver, select the placeholder text in the next <article> element.  Paste the copied text using Paste Special.
12. In Word, copy “Cable Car Tips” and its paragraphs.  Use Paste Special to paste the content in place of the placeholder text of <aside> element.  
13. Save your work.  Ctrl +S

	Footer with a Special Character 
HTML Entities or Special Characters – Some characters are not available on your keyboard and need to be inserted into HTML as an HTML entity (special character).  They always begin with and ampersand (&) and end with a semicolon (;).  Example = &copy;, &rsquo;

Footers on web pages usually contain copyright information.


	Hands-On Practice:
8. Select the placeholder text in <footer> element.  Delete the text.  Insertion point should now be between the two <footer></footer> tags.
9. In the Property inspector, click to reveal the Format menu and select Paragraph. It inserted two <p> tags with a &nbsp; in between.



Continued on next page
10. Insert a copyright symbol to take the place of &nbsp; by:  In the Insert panel, choose Common.  At the bottom of the panel click Character, then Copyright. 
11. In the HTML code insert a space and type “Copyright 2015 Bayside Beat”.  
12. Save the page.  Ctrl+S





	Dreamweaver Lesson 2b Review Questions
1.  What are two advantages of using rich text format (.rtf) files for the text content of a website you create?
2.  What is placeholder text?
3. Why did we use Paste Special instead of Paste when we placed the copied text content into the Bayside Beat website?
4. Explain how to insert a copyright symbol and other special characters not found on the keyboard into HTML code using Dreamweaver.


	Instructions:  In a new Word document, re-type the review questions to the left.  Type your response to each question.  Include a header with your name, DW Lesson 2b Questions, and Class Period.

	Other Notes:



















	





Dreamweaver Bayside Beat Notes
Part 2c
Inserting Images, Image Captions, Add Internal/External Links






	Inserting Images:
Tag Selector – Located in the bottom left of the Dreamweaver document window.  It displays a list of tags showing where you are in the HTML structure.  Clicking a tag in the Tag selector will select the entire element.  This allows you to easily delete, copy, cut or perform other functions with that tag and all of its contents.

Details of images (including width and height) are displayed in the Property inspector.  

Alt Text – Alternative text describes the image for search engines.  It is also descriptive text for non- visual browsers such as technology for the blind.



	Hands-On Practice:
14. Insert the hero (main) image by:  click anywhere in the “Be Where it’s At” heading or paragraph.  In the Tag selector, select <article>.  
15. Move the insertion point between closing </article> and closing tag of the hero <div>. 
16. In Insert panel, Common, click Image.  In the dialog box navigate to the images folder in the Bayside Beat site, and select golden_gate.jpg.  Click OK.
17. In Property inspector, delete the values for the W and H of the image.  In the Alt field, enter descriptive text such as “Golden Gate Bridge in San Francisco Bay”.  Press Tab.

	Inserting Images with Captions:
Caption – this is text that is displayed below the image. 


















Add Internal Links: 
Links as anchor tags – Historically, links were called “anchors”, so they use the <a> tag.  

Hypertext reference – hypertext is the technical name for a text link. 

Hypertext Links are identified by blue underlined text.  

Internal Links vs. External Links – Internal links take users to another page on the site or to a place within the site.  External Links take users to a completely different web site.


Three ways to create an internal link – First, Use the Browse for File button.  Second, Use the Point to File button.  Third, type the name of the file you are linking to.  The first two options are usually more accurate.
	Hands-On Practice:
1.  In Design view, click anywhere inside the second paragraph of the heading “Riding the Cable Cars”. 
2. Select the <p> tag in the Tag selector.  Move the insertion point between the closing </p> tag of the second paragraph and the opening <p> tag of the third.  
3. In Insert panel, switch to Structure and click Figure.  Delete the placeholder text between the <figure></figure>.
4. Switch back to Common category of the Insert panel.  Click Image. Select cable_car1.jpg from the images folder.  Do not add Alt text, because we will add a caption.
5. Select the placeholder text in the <figcaption> element and replace it with “The cable car terminus near Union Square.”
Hands on Practice: 
1.  Create a new HTML page to link to by: Select File>New.  In the dialog box select Blank Page , set Page Type to HTML.  Layout should be <none>.  Click Create.
2. In Design view, type “Sightseeing”  just to identify the page.  Save the new page in the Bayside Beat site root as sightseeing.html  Close the page by clicking the X on its tab. 
3.  Turn the list item, “Sightseeing”  in the bulleted list into an internal link by: In index.html, select Sightseeing in the bulleted list. In Property inspector, click Browse for File icon next to the Link text box. In the dialog box select sightseeing.html and click OK.  In Design view, the Sightseeing text should now appear blue and underlined to indicate it is a link.
4. Turn the list item, “Home” in the bulleted list into an internal link by:   Select Home in the bulleted list. Open the Files panel.  In Property inspector click Point to File icon (it looks like a cross hair).  Hold down the mouse and drag the icon toward the Files panel, release the mouse when the crosshair is over index.html in the Files panel.
5. Convert the remaining three list items into dummy links by selecting the text, then enter the hash sign (#) in the Link text box. Save your work.  Ctrl+S
6. Preview index.html in a browser by:   Click the globe icon in the top right of Dreamweaver window and choose your default browser.
7. Text the Sightseeing link.  Click the link.  You should be taken to the temporary sightseeing page. The other three links will not work at this time.



Continued on Next Page

	Add an External Link:  
The most reliable way to create an external link is to load the page in a browser, then copy and paste the exact URL.  You must include the http:// portion of the URL for it to work correctly.  
	Hands On Practice: 
1.  Create an external link by: Open content1.rtf from the content folder you downloaded previously.  Scroll to the bottom of the document to view the three suggested external links for index.html. Select the URL for Fisherman’s Wharf, Copy it Ctrl+C
2. In Dreamweaver, Select the text “Fisherman’s Wharf” in the <article> element.  In Property inspector, paste the copied URL in the Link text field.  Press Tab.
3. Do the same for the Muni Passport URL and its corresponding text in the <aside> element. (Remember to Press Tab after pasting the URL.
4. Save the page.  Ctrl+S.
5. View index.html in a browser.
6. Click the links to verify that they work.

	Dreamweaver Lesson 2c Review Questions
1.  What happens in the HTML code when you click on a tag in the Tag Selector?  
2.  Explain the steps for inserting an image in Dreamweaver.
3. What is “alternate text” as it pertains to images on a web page?
4. Name three ways to create an internal link in Dreamweaver.
5. What is the most reliable way to create an external link in Dreamweaver?


	Instructions:  In a new Word document, re-type the review questions to the left.  Type your response to each question.  Include a header with your name, DW Lesson 2c Questions, and Class Period.

	Other Notes:












	



Dreamweaver Bayside Beat Notes
Part 3a
CSS Designer Panel, External Style Sheet, Basic CSS Styles





	CSS Designer:
Cascading Style Sheets (CSS) – these are formatting rules that control the appearance of content on a web page.  

The CSS Designer panel in Dreamweaver contains 4 panes:
· Sources- lists all sources of styles that apply to the current page
· @Media – manages media queries that apply styles based on browser needs.  We won’t use this pane much right now.
· Selectors – manage the style rules for the current page
· Properties – Set the properties for individual style rules.  Contains 5 sections: Layout, Text, Border, Background, and Others
For extra help understanding CSS, go to w3schools.com/css

External Style Sheets:  The content of your page resides in the HTML file.  The rules defining the presentation of that code reside in another file, the external style sheet. 

Changes made to rules in an external style sheet are automatically applied to every page attached to it. 


	Hands-On Practice:
18. Create a new CSS file by:  In Dreamweaver, close the Files and/or Insert panels if necessary.  Click the CSS Designer tab and open it to its full height.
19. Notice the four different panes in the CSS Designer panel.  Click the plus + button in the Sources pane.  Select Create A New CSS File.  In the dialog box, click Browse to open the Save Style Sheet As dialog box.
20. Create a new folder (Right Click>New>Folder) called “styles” in the bayside_beat folder. Navigate inside the new folder.
21. In the File Name text field type main.css.  Click Save.
22. In the Create a New CSS File dialog box click OK. (Link button should be selected)  main.css should be listed in the Sources pane now.
23. In the HTML code, the style sheet should be attached within the <head> element with a <link> tag.
24. Switch from Split view to Design view.

	Creating Selectors:
In CSS, selectors allow you to select and manipulate certain HTML elements.  Selectors “find” HTML elements based on their id, class, type, attribute, etc.
For extra help understanding selectors, go to w3schools.com/css/css_selectors.asp


When a selector is selected, the Properties pane will allow you to apply CSS rules.  Any value that is displayed in light gray italic text indicates that the property has not yet been set.  They will turn black when they have been set.

Text Color – most designers agree that very dark gray text on a white background is easier on the eyes than black on white.

Remember, a good resource for obtaining color hexadecimal codes is www.color.adobe.com

ID Selectors – all ID selectors begin with a # sign.


When setting the values in CSS, do not put a space between the value and the unit of measurement.  Example:  1000px










	Hands-On Practice:
6. Add a new selector by:  make sure main.css is selected in the Sources pane of  CSS Designer.  Click the plus + button at top right of Selectors pane.  Replace the suggested value with “body”.  Press Enter twice
Continued on next page
7. With the new body selector selected, the Properties pane will display the CSS properties you can apply to it.  Click the Text icon at the top of the Properties pane. Click “undefined” next to the color property and enter #151515.  Press Enter
8. Click “default font” next to the font-family and select the font stack that begins with Gill Sans.
9. Click the Background icon. Set the background-color property to #EFF5F8. Press Enter. This turns the background pale blue.
10. Create a new selector by: click the plus + button in the Selectors pane. Type #wrapper.  Press Enter twice.
11. Click the Background icon, click the color box next to background-color.  Select a white.
12. Click the Layout icon. Click “auto” next to the width property.  Select % from the menu. Set the width to 100%.
13. Set the value of min-width to 740 px.  Set the value of max-width to 1000px.
14. On the margin visual tool, click “px” on the left and right and select “auto” from the menu.
15. Create a style for the image of the Golden Gate Bridge by: click the plus + button in the Selectors pane.  Type #hero img.  Press Enter twice.  
16. On the Layout icon, set the max-width to 100%.
17. Save both the HTML page and the style sheet by: Select File> Save All Related Files.







Continued on Next Page

	Dreamweaver Lesson 3a Review Questions
1.  What do the letters CSS stand for and what does CSS do?
2.  Why is it more efficient to use an external CSS file instead of just adding CSS rules into the head section of an HTML document?
3. We created a new CSS file and a new folder to store it in.  What was the name of the file and what was the name of the new folder?
4. In Dreamweaver, what are the names of the four panes within the CSS Designer Panel?
5. In the Properties Pane of the CSS Designer Panel, what are the names of the five sections (five icons at the top)? 
6. What does “Save All Related Files” do?



	Instructions:  In a new Word document, re-type the review questions to the left.  Type your response to each question.  Include a header with your name, DW Lesson 3a Questions, and Class Period.

	Other Notes:


























	


Dreamweaver Bayside Beat Notes
Part 3b
Web Fonts, Style the Main Heading, CSS Float, Style the Footer, Style the Image, Position the Caption






	Adobe Edge Web Fonts:
For the sake of time we will not practice using Adobe Edge Web Fonts, but here is what you need to know about them:  Browsers normally rely on the fonts installed on the user’s computer.  For a long time, this restricted the range of fonts available to web designers.  Fortunately, that has changed due to the availability of a wide range of downloadable fonts.  Adobe servers provide a collection of 500+ free fonts that can easily be applied to sites created in Dreamweaver CC. Adobe Edge Web Fonts will generate a link to a remote JavaScript file that downloads the fonts to the user’s browser when your page is viewed. For more information go to https://edgewebfonts.adobe.com

What is scrubbing? Scrubbing is a common technique for changing values in many Adobe applications.  When you place your mouse over a value in a text field your cursor turns to a double sided arrow.  Click and hold while dragging (scrubbing) to the right to increase the value or scrub to the left to decrease the value.

	Hands-On Practice:
25. Style the main heading by:  On the CSS Designer tab in Dreamweaver, make sure main.css is selected and create a new selector called “h1” . (Click the + button in the Selectors Pane, type h1 then Enter twice.)
26. Click the Text icon.  Click medium next to the font-size property, and select px from the menu.  Set the value to 72px
27. Center the heading by setting the text-align property to center.
28. Convert the heading to uppercase by setting text-transform to uppercase.
29. Get rid of gaps at the top or bottom of the page by: Click the Layout icon, set top and bottom margins to 0px.


	Create columns with CSS floats:
Because of the way we grouped the <div>, <article>, and <aside> elements they are stacked vertically on top of each other. To move the elements to the left or right and allow the following element to move up alongside them we will use the CSS float property.

Naming CSS Selectors:  Recall that selectors are used to specify which element of the HTML code the CSS will style.  Remember it is important to name selectors with a # using the same ID you assigned them previously. 
 Example if id=”main” in your HTML code, then in CSS the selector needs to be named #main.  You only use # in the selector if you have given the element an id=.  









	Hands-On Practice:
1. Create two columns on the web page by: make sure main.css is selected. Create a new selector (using the + key) called #main.
2.  In the Layout section of #main set the following properties:  width : 58%, margin-left: 2%, float: left
3. Create another new selector (+ key) called #sidebar.  In the Layout section set the following properties:  width: 34%, margin-left: 4%, float: left   
4. If the copyright symbol has moved up alongside the section too you can try fixing it by: create a new selector called footer and set the following properties in the Layout section:  clear: left, top and bottom padding: 2px, left padding: 2%.  In the Background section of the footer selector, set background color to #43A6CB.  In the Text section set color to white (#FFFFFF).
5. Save the web page and style sheet by selecting File>Save All Related Files.
6. View the web page in a browser or Live view.




	Captions:   A caption is descriptive text that appears below an image.  

CSS Classes:  To apply the same style to multiple elements in a page, you need to create a CSS class.  A class is similar to an ID, except it can be used more than once on a page.  How to distinguish between classes and IDs?  Class selectors begin with a dot (.) and ID selectors begin with a  pound sign (#).
	Hands-On Practice:  
1.  Style the image with a caption by: select main.css from the Sources pane.  Create a new selector called figure.  On the Layout icon, set width: 420px
2. Create a new selector called figcaption.  In the Layout icon set display: block. In the Text icon, set font weight: bold, font-size: 14px, text-align: center
3. Position the <figure>element by: select main.css.  Create a new class selector called .centered.  (Don’t forget to begin with a dot.) On the Layout icon set left and right margins: auto.  
4. Create a new class selector called .floatleft.  In the Layout icon set right margin to 10px. Set float:left
5. Create a new class selector called .floatright.  In the Layout icon set left margin:10px, float:right
6. 

	CSS to Create Photo Effect:   Adding background color, padding and a drop shadow can help images not look so flat on your page. 
	Hands-On Practice:  
1.  Make sure main.css is selected.  Turn on Live view.  Keep related styles together for easier maintenance by clicking “figure” in the Selectors pane then create a new selector called figure img.  On the Layout icon, click the chain icon and set padding:10px on all sides.  
2. In Background icon, set the following properties:  background-color:white (#FFFFFF), box-shadow:color#999999, h-shadow:1px, v-shadow:1px, blur:15px.  This creates a thin border on the right and bottom that can appear as a drop shadow.  
3. Move the image and caption into position by:  Turn off Live view.  Click anywhere in the caption under the image.  Right-click <figure> in the Tag selector.  Choose Set Class>centered.  Turn on Live view.  The image and caption should now be centered in the main <article>.
4. File>Save All Related Files.

	Dreamweaver Lesson 3b Review Questions
1.  What is an advantage of using Adobe’s Edge Web Fonts when designing a web page?
2.  What is a CSS selector?
3. How do you create a new selector in CSS Designer?
4. In our practice web page, what did we use the CSS float property for?
5. We created a footer selector in our practice web site.  Why was it named “footer” not “#footer”?
6. How do you distinguish between a class selector and an ID selector?  
	

	Instructions:  In a new Word document, re-type the review questions to the left.  Type your response to each question.  Include a header with your name, DW Lesson 3b Questions, and Class Period.

	Other Notes:




	

















	
	Dreamweaver Bayside Beat Notes
Part 4a
Styling Links, Navigation Bar, 







	Interactive Links:  Links are interactive.  They have various states such as:  visited, active, unvisited and hover.

Pseudo-classes:  A pseudo-class is used to define a special state of an element.
For example, it can be used to:
· Style an element when a user mouses over it
· Style visited and unvisited links differently
The syntax of pseudo-classes: (How it looks in your HTML code)
selector:pseudo-class {
    property:value;
}
Order of Pseudo-Classes:
For the styles to be applied to links correctly they must be in the following order in your style sheet:
a: link 
a: visited
a:hover
a:active
Remember it by LoVeHAte (LVHA)
	Hands-On Practice:
30. Add CSS style to the existing links by:  select main.css in Sources Pane.  Create a new selector called “a” to style links in all states.
31. In the Text icon, set the following:  font-weight: bold, text-decoration: none
32. Create a new selector called a:link (no space between the a and the colon)  In the Text icon, set the color property to orange (#FF6600)
33. Create a new selector called a:visited(no spaces) and set color property to lighter shade of orange (#FF944C)
34. Create a group selector called a:hover, a:active, a:focus .  In the Text section set the following:  color: #7F3300, text-decoration: underline
35. Turn on Live view to see the links change when they are hovered over.



	Create a navigation bar with CSS:  To do this we will remove the bullets, padding and margin from the unordered list.  The links get converted into buttons by giving them width and floating them.  

Margin vs. Padding
Padding is the space between the content and the border, whereas margin is the space outside the border




[image: ]








	Hands-On Practice:
1.  Convert the unordered list of links into a navigation bar by:  select main.css in the Sources Pane.  Create a new selector called #mainnav ul 
2. Click the Layout icon  and set list-style-type to none (no more bullets).  Set the margin and padding to zero on all sides by clicking the chain icon.
3. Create a new selector called #mainnav a to style all links nested in the <nav> with the ID mainnav.  Set the width property to 20% (since there are 5 links 100%/5 = 20%)  Set display to block (on Layout icon).  
4. This turns the whole element into a clickable button, not just the text. Set float to left.  Links should be in single line now.
5. In the Text icon, set text-align to center.
6. In Background icon, set background-color to #4D4D4D (dark gray)
7. In Text icon, set color: white, text-transform :uppercase, top and bottom padding: 6px
8. To change the look of the links when hovered over do the following:  Create a new group selector called: #mainnav a:hover, #mainnav a:active, #mainnav a:focus, #mainnav a.thispage .  In the Text icon set text-decorate: none.  In Background icon set background-color: #43A6CB (aquamarine)
9. Turn off Live View.  Click the Home Link.  In the Property inspector select thispage from the Class menu.  Turn on Live View again.
10. File>Save All Related Files.  


	Dreamweaver Lesson 4a Review Questions
1.  What does it mean to say that links have a status?
2.  What are the default colors for unvisited and visited links?
3.  What pseudo-classes for links did we learn today and does it matter what order they appear in a style sheet?  What is the order? 
4. What is the difference between margin and padding? 
	


	Instructions:  In a new Word document, re-type the review questions to the left.  Type your response to each question.  Include a header with your name, DW Lesson 4a Questions, and Class Period.



Dreamweaver Bayside Beat Notes
Part 4b
Absolute Positioning with CSS, Older Browsers





	Absolute Positioning:  Allow you to specify the precise position of an element.  Normally, HTML elements expand and contract to fit the content you put in them.  Example:  Add information to an <article> and it gets longer, pushing content that is below it further down the page.  Absolute positioning takes elements out of that normal page flow and puts them on independent layers. This could cause content to overlap which could be good or bad.  
Elements are positioned inside a containing block.  With CSS, you can offset top, bottom, left and right properties of an element in its containing block. Positive values move the element toward the center of the containing block, negative values move it in the opposite direction.  
An element’s containing block is defined by:
· The containing block is the nearest positioned element higher up the HTML family tree.
· If no such element exists, the page is the containing block.
Troubleshooting:  Are elements moving around on your page after you’ve carefully positioned them?  Solution:  Set the position property of the absolutely positioned element’s parent to relative.  Now if the parent moves, the absolutely positioned element moves in sync.




Properties with a color box have the option of using an eyedropper tool.  Use this tool to sample existing colors on the web page for an exact match of text or background.





Tip:  To see which properties have been set for a selector, click the Show Set check box at the top-right of the Properties pane
	Hands-On Practice:
1.  Position the hero<div> <article> on top of the large sky area of the hero image by:  turn on Live view and select main.css in the Sources pane.
2. Keep related styles together in your CSS by selecting #wrapper in the Selectors pane then create a new selector called #hero. In the Layout icon set position: relative.  Press Tab.
3. Create a new selector near #hero and call the new one #hero article. On the Layout icon set width:36%, left and right padding:10px, Position: absolute.  <article> moves inside the hero <div>, but the heading overlaps the navigation bar.  
4. Fix the overlap by: select #hero in the Selectors pane.  Set clear: left
5. Continue styling by: select #hero article in the Selectors pane.  Scrub the top and right offsets in the position tool to move the article to the top right area of the image.  On the Background icon, click the color box next to background-color, use the eyedropper tool to sample a light orange color from the bridge. Press Enter.
6. Create rounded corners by: click the chain icon in the border-radius tool.  Scrub one of the values to create evenly rounded corners.  About 14px.
7. On the Text icon, set color:white (#FFFFFF)  Only the paragraph turns white due to a rule setting <h2>.

Continued on next page
8. Create a new selector for #hero h2.   On the Text icon, set color:white, text-transform: uppercase
9. Reduce the vertical space around heading by: scrub the top margin to about 5px and bottom margin to about 7px.
10. File>Save All Related Files


	Dealing with Older Browsers: Remember that not all users have the most up to date browsers.  You need to make sure that your web pages aren’t completely broken in older browsers.  The main problem seems to be with Internet Explorer 6-8 which won’t apply styles to new HTML5 elements without a little help.  







The JavaScript file helps IE 6-8 (Internet Explorer 6-8) recognize the new HTML5 structural elements so that older browsers can style them with CSS.  However, even with this there are some new CSS properties that the older browsers still won’t support without some more in depth steps that we won’t cover right now.
	Hands-On Practice:  
1.  Create a simple style rule for older browsers to display certain elements as blocks by:  select main.css in the Selectors Pane.  Create one new selector called:  article, aside, figure, footer, header, nav.  On the Layout icon set display: block.  Press Tab.  Turn off Live view.
2. Click Source Code under the index.html tab.  Change to Split view to reveal the HTML code.  Move the insertion point to immediately before the closing </head> tag.  
3. Select Insert>Script.  In the dialog box navigate to the js folder and select html5shiv.js. Click OK. This inserts a line of code just before the closing </head>.
4. Select the line of new code and click Window>Snippets.  This opens the Snippets panel. In the panel, expand the Comments folder and select Less Than or Equal to IE 7 Conditional Comment. Click Insert once. This wraps the <script> code you just inserted with a comment <!>.  
5. Add IE 8 to the JavaScript file by: change [if lte IE 7] to [if lte IE 8]
6. Select Commands>Apply Source Formatting
7. File> Save All Related Files.  Close the Snippets panel.






Continued on next page

	Dreamweaver Lesson 4b Review Questions
1.  What does absolute positioning allow you to do?
2.  Why did we have to set the position of the #hero article to absolute?  
3. Explain when you would use the eyedropper tool from the CSS Designer panel in Dreamweaver?
4. How can you quickly see which properties have been set on each selector without scrolling through the entire property list?
5. We added a JavaScript file to our HTML code.  What did that file do?  
	


	Instructions:  In a new Word document, re-type the review questions to the left.  Type your response to each question.  Include a header with your name, DW Lesson 4b Questions, and Class Period.

	Other Notes:






























	


Dreamweaver Bayside Beat Notes
Part 5
Adding Additional Pages





	Why More Pages?  One page is not usually sufficient for a website.  The homepage or landing page generally contains an eye-catching large image (hero image).  This page helps set the mood for the site.  Inner pages usually give greater emphasis to text.  

Create additional page(s) by copying the existing page and simply replacing its content.  Start by attaching the style sheet that was created for the homepage (main.css).  Then build the HTML structure and add the text content




	Hands-On Practice:
11. Attach the existing style sheet by: open sightseeing.html, you created this temporary page in Part 2.
12. In the CSS Designer panel, click the + button in the Sources pane and choose Attach Existing CSS.  In the dialog box, Browse for main.css in the styles folder. Click OK. Click OK again to close the Attach Existing CSS File dialog box. (The background of sightseeing.html and font should already look different due to the style sheet at work)


	Don’t forget the Title!  It is a common mistake for beginners to forget to replace “Untitled Document” with an appropriate title.  This title is not only displayed in the browser tab but it is also used by search engines.  It would be embarrassing to have your great website be listed in search results as “Untitled Document”.
















Remember, an ID can only be used once on a page, so the ID, wrapper, will not be listed as an option after using it here.  


Rules for Copying and Pasting in the Document Window of Dreamweaver
· Always paste into the same view as you copied from.
· If you copy in Design view, paste into Design view.
· If you copy in Code view, or you copy code from an external resource, paste into Code view.
	Hands-On Practice:  
1.  Build the HTML structure of the second page by:  in Design view, delete the existing text in sightseeing.html.  (The page will be completely blank now.)
2. Replace “Untitled Document” in the Title text field located in Property inspector with “Sightseeing in San Francisco”.
3. Open index.html.  Work in Design view. Click the main BAYSIDE BEAT heading. Select <header#top> in the Tag selector. This will select the heading.  Copy it Ctrl+C.  Switch to sightseeing.html, click in Design view and paste Ctrl+v.  You just copied the heading and navigation bar into the second page.
4. Wrap the wrapper <div> around the elements you just pasted by:  click anywhere inside the main heading and select <header#top> in the Tag selector.

Continued on next page  
5. Open the Insert panel, select Structure and click Div.  In the dialog box specify the following:  Insert at: Wrap around selection, ID:wrapper.  Click OK.  When you click away from the content selected in Design view you should see a white background behind the main heading.
6. Next, insert the main <article> by:  Click Article in the Insert panel. Specify the following:  Insert:  After Tag, <header id=”top”>, ID: main.  Click OK.
7. Insert the sidebar by:  Click Aside in the Insert panel and specify the following:  Insert: After tag, <article id=”main”>, ID:hero
8. Add <footer> to the structure by:  switch back to index.html, click anywhere inside the <footer> and select <footer> in the Tag selector.  Copy it Ctrl+C  Switch back to sightseeing.html, click inside the sidebar placeholder text and select <aside#sidebar> in the Tag selector.  Press the right arrow key > once to move the insertion point to the right of the closing </aside> tag.  (Do NOT click there in Code view!) Paste Ctrl+V  You should now have a main heading, navigation bar, two columns (one for “main” and one for “sidebar”, and a footer.


	The content for sightseeing.html is found in the content folder.  It is content2.rtf.  





Using Paste Special preserves the format of information copied from Word as you paste it into Dreamweaver.







Refer to Part 2 “Adding Links” for a reminder of how to create links, if needed.  




	Hands-On Practice:
1.  Add the text content by: Open content2.rtf from the content folder.  It will open in Word.  Copy the first heading and the following six paragraphs.  Ctrl+C
2. Switch back to sightseeing.html in Dreamweaver, and select the “Content for id ‘main’ Goes Here” placeholder text.  Select Edit>PasteSpecial.  If pasting from Microsoft Word, select the third radio button in the Paste Special dialog box.
3. Copy and paste the remaining text from content2.rtf into the <aside> element using the same steps.  

Continued on next page
4. Use the list of suggested links to external sites in content2.rtf (second page) to create links by:   Select the relevant text in Design view and paste the URL into the Link text field in the Property inspector.

	Current Page Button:  At this point, we need to fix a problem on the navigation bar.  When we copied the <header> from index.html, all the HTML code was copied with it.  In that code resides a class called thispage.  In order for the Sightseeing button on the navigation bar to have an aquamarine background signaling it is the current page, we need to remove the thispage class from the Home link and apply it to the Sightseeing link.  
	Hands-On Practice: 
1.   Fix the current page button on the navigation bar by:  On sightseeing.html, click anywhere in the Home link and right-click <a.thispage> in the Tag selector. Select Set Class>None from the menu.
2. Click anywhere in the Sightseeing link.  Right-click <a> in the Tag selector, and select Set Class>thispage from the menu.

	Insert Images and Captions:  There are two images for sightseeing.html.  Remember when organizing your own files to put all images in a folder called “images”.



Oops!  Remember to use Ctrl+Z to undo a mistake.
	Hands-On Practice:
1.  Insert the first image between the first and second paragraphs of text by:  Click anywhere inside the first paragraph in the main <article> and select <p> in the Tag selector.  Press the right arrow key > once to move the insertion point between the first and second paragraphs.
2. In the Structure category of the Insert panel, select Figure to insert a <figure>element with a <figcaption> nested inside.  You should now see placeholder text for both the image and the image caption.
3. Delete the placeholder text for the image only.  From the top menu bar select Insert>Image>Image and select cable_car2.jpg from in the images folder.
4. Replace the caption placeholder text with “The front seat of a cable car affords a great view of the city.” Make the text flow around the image and caption by:  click anywhere inside the caption, right-click <figure> in the Tag selector.  Select Set Class>floatright from the menu.
5. Insert alcatraz.jpg between the third and fourth paragraphs by repeating the steps above.  Give it a caption of “Alcatraz – former exclusive residence for notorious criminals”.  Set the class of the <figure> to floatleft.             Continued on next page
6. Check out your work in Live view.
7. One last finishing touch.  Recall in the last of Part 4, we attached a JavaScript file to ensure that IE 6-8 will apply styles to the new HTML5 elements.  Attach this same file to sightseeing.html by:  Open index.html in Code view.  Copy the code that begins with <!—[if let IE 8]> and ends with <![endif]- - >  In sightseeing.html, open Split view and paste the code you copied just before the closing </head> tag.
8. Save your work Ctrl+S.

	Dreamweaver Lesson 5 Review Questions
6. In your opinion, why is it recommended to have more than one page on a website?
7. In your opinion, what should appear on the home page or “landing page” of a website?
8. Explain the basic order or how to create a second page for a site after you’ve already created a home page.
9. Summarize the rules for copying and pasting in Dreamweaver.
10. Explain the basic steps for inserting an image with a caption.
		
	Instructions:  In a new Word document, re-type the review questions to the left.  Type your response to each question.  Include a header with your name, DW Lesson 5 Questions, and Class Period.

	Other Notes:
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